
<!DOCTYPE html>

<!--[if lt IE 7]><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8 lt-ie7"> <![endif]-->
<!--[if (IE 7)&!(IEMobile)]><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#" class="no-js lt-ie9 lt-ie8"><![endif]-->
<!--[if (IE 8)&!(IEMobile)]><html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#" class="no-js lt-ie9"><![endif]-->
<!--[if gt IE 8]><!--> <html lang="en-US" xmlns:fb="https://www.facebook.com/2008/fbml" xmlns:addthis="https://www.addthis.com/help/api-spec"  prefix="og: http://ogp.me/ns#" class="no-js"><!--<![endif]-->

	<head>

		<meta charset="utf-8">

		<!-- Google Chrome Frame for IE -->
		<!--[if IE]><meta http-equiv="X-UA-Compatible" content="IE=edge" /><![endif]-->
		<!-- mobile meta -->
                    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>
        
		<link rel="pingback" href="https://boyleheightsbeat.com/xmlrpc.php">

		
		<!-- head functions -->
		<title>2 women wanted for fleeing street race crash, leaving driver severely injured - Boyle Heights Beat</title>
<link rel="alternate" hreflang="en-us" href="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/" />

<!-- This site is optimized with the Yoast SEO Premium plugin v8.1.2 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="2 women wanted for fleeing street race crash, leaving driver severely injured - Boyle Heights Beat" />
<meta property="og:description" content="A $25,000 reward is being offered for information leading to suspects in Boyle Heights hit-and-run" />
<meta property="og:url" content="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/" />
<meta property="og:site_name" content="Boyle Heights Beat" />
<meta property="article:publisher" content="https://www.facebook.com/Boyle-Heights-Beat-216347485050035/" />
<meta property="article:tag" content="Boyle Heights" />
<meta property="article:tag" content="hit-and-run" />
<meta property="article:section" content="Boyle Heights In Focus" />
<meta property="article:published_time" content="2020-11-20T22:30:50-08:00" />
<meta property="article:modified_time" content="2020-11-20T22:44:28-08:00" />
<meta property="og:updated_time" content="2020-11-20T22:44:28-08:00" />
<meta property="og:image" content="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run-1024x640.png" />
<meta property="og:image:secure_url" content="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run-1024x640.png" />
<meta property="og:image:width" content="1024" />
<meta property="og:image:height" content="640" />
<meta name="twitter:card" content="summary" />
<meta name="twitter:description" content="A $25,000 reward is being offered for information leading to suspects in Boyle Heights hit-and-run" />
<meta name="twitter:title" content="2 women wanted for fleeing street race crash, leaving driver severely injured - Boyle Heights Beat" />
<meta name="twitter:site" content="@boyleheightsbt" />
<meta name="twitter:image" content="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run.png" />
<meta name="twitter:creator" content="@boyleheightsbt" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/boyleheightsbeat.com\/","sameAs":["https:\/\/www.facebook.com\/Boyle-Heights-Beat-216347485050035\/","https:\/\/www.youtube.com\/user\/boyleheightsbeat","https:\/\/twitter.com\/boyleheightsbt"],"@id":"https:\/\/boyleheightsbeat.com\/#organization","name":"Boyle Heights Beat","logo":"https:\/\/boyleheightsbeat.com\/wp-content\/uploads\/2017\/01\/BoyleHeightsBeatLogoLG.jpg"}</script>
<!-- / Yoast SEO Premium plugin. -->

<link rel='dns-prefetch' href='//netdna.bootstrapcdn.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Boyle Heights Beat &raquo; Feed" href="https://boyleheightsbeat.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Boyle Heights Beat &raquo; Comments Feed" href="https://boyleheightsbeat.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Boyle Heights Beat &raquo; iCal Feed" href="https://boyleheightsbeat.com/events/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Boyle Heights Beat &raquo; 2 women wanted for fleeing street race crash, leaving driver severely injured Comments Feed" href="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.0\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/boyleheightsbeat.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=5.5.3"}};
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='widget-calendar-pro-style-css'  href='https://boyleheightsbeat.com/wp-content/plugins/events-calendar-pro/src/resources/css/widget-theme.min.css?ver=4.7.2' type='text/css' media='all' />
<link rel='stylesheet' id='tribe-tooltip-css'  href='https://boyleheightsbeat.com/wp-content/plugins/the-events-calendar/common/src/resources/css/tooltip.min.css?ver=4.9.9' type='text/css' media='all' />
<link rel='stylesheet' id='wp-block-library-css'  href='https://boyleheightsbeat.com/wp-includes/css/dist/block-library/style.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='wpml-legacy-horizontal-list-0-css'  href='//boyleheightsbeat.com/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-list-horizontal/style.css?ver=1' type='text/css' media='all' />
<style id='wpml-legacy-horizontal-list-0-inline-css' type='text/css'>
.wpml-ls-statics-shortcode_actions, .wpml-ls-statics-shortcode_actions .wpml-ls-sub-menu, .wpml-ls-statics-shortcode_actions a {border-color:#cdcdcd;}.wpml-ls-statics-shortcode_actions a {color:#444444;background-color:#ffffff;}.wpml-ls-statics-shortcode_actions a:hover,.wpml-ls-statics-shortcode_actions a:focus {color:#000000;background-color:#eeeeee;}.wpml-ls-statics-shortcode_actions .wpml-ls-current-language>a {color:#444444;background-color:#ffffff;}.wpml-ls-statics-shortcode_actions .wpml-ls-current-language:hover>a, .wpml-ls-statics-shortcode_actions .wpml-ls-current-language>a:focus {color:#000000;background-color:#eeeeee;}
</style>
<link rel='stylesheet' id='wpml-legacy-post-translations-0-css'  href='//boyleheightsbeat.com/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/legacy-post-translations/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='wpml-menu-item-0-css'  href='//boyleheightsbeat.com/wp-content/plugins/sitepress-multilingual-cms/templates/language-switchers/menu-item/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://boyleheightsbeat.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.min.css?ver=4.7.6' type='text/css' media='all' />
<link rel='stylesheet' id='wordpress-popular-posts-css-css'  href='https://boyleheightsbeat.com/wp-content/plugins/wordpress-popular-posts/assets/css/wpp.css?ver=5.1.0' type='text/css' media='all' />
<link rel='stylesheet' id='fontawesome-css'  href='//netdna.bootstrapcdn.com/font-awesome/latest/css/font-awesome.css?ver=1.3.9' type='text/css' media='all' />
<link rel='stylesheet' id='addthis_all_pages-css'  href='https://boyleheightsbeat.com/wp-content/plugins/addthis/frontend/build/addthis_wordpress_public.min.css?ver=5.5.3' type='text/css' media='all' />
<link rel='stylesheet' id='cb-main-stylesheet-css'  href='https://boyleheightsbeat.com/wp-content/themes/valenti/library/css/style.css?ver=5.4' type='text/css' media='all' />
<link rel='stylesheet' id='cb-font-stylesheet-css'  href='//fonts.googleapis.com/css?family=Oswald%3A400%2C700%2C400italic%7C%3A400%2C700%2C400italic&#038;subset=greek%2Cgreek-ext&#038;ver=5.4' type='text/css' media='all' />
<!--[if lt IE 9]>
<link rel='stylesheet' id='cb-ie-only-css'  href='https://boyleheightsbeat.com/wp-content/themes/valenti/library/css/ie.css?ver=5.4' type='text/css' media='all' />
<![endif]-->
<link rel='stylesheet' id='cb-child-stylesheet-css'  href='https://boyleheightsbeat.com/wp-content/themes/boyleheightsbeat/style.css?ver=1.1' type='text/css' media='all' />
		<style>
			/* Accessible for screen readers but hidden from view */
			.fa-hidden { position:absolute; left:-10000px; top:auto; width:1px; height:1px; overflow:hidden; }
			.rtl .fa-hidden { left:10000px; }
			.fa-showtext { margin-right: 5px; }
		</style>
		<script type='text/javascript' id='wpp-js-js-extra'>
/* <![CDATA[ */
var wpp_params = {"sampling_active":"0","sampling_rate":"100","ajax_url":"https:\/\/boyleheightsbeat.com\/wp-json\/wordpress-popular-posts\/v1\/popular-posts","ID":"35959","token":"60ee4d8385","debug":""};
/* ]]> */
</script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/plugins/wordpress-popular-posts/assets/js/wpp-5.0.0.min.js?ver=5.1.0' id='wpp-js-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/themes/valenti/library/js/modernizr.custom.min.js?ver=2.6.2' id='cb-modernizr-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp' id='jquery-core-js'></script>
<link rel="https://api.w.org/" href="https://boyleheightsbeat.com/wp-json/" /><link rel="alternate" type="application/json" href="https://boyleheightsbeat.com/wp-json/wp/v2/posts/35959" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://boyleheightsbeat.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://boyleheightsbeat.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 5.5.3" />
<link rel='shortlink' href='https://boyleheightsbeat.com/?p=35959' />
<link rel="alternate" type="application/json+oembed" href="https://boyleheightsbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboyleheightsbeat.com%2F2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://boyleheightsbeat.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fboyleheightsbeat.com%2F2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured%2F&#038;format=xml" />
<meta name="generator" content="WPML ver:4.2.6 stt:1,2;" />

		<script>
			(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
			(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
			m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
			})(window,document,'script','https://www.google-analytics.com/analytics.js','ga');
			ga('create', 'UA-25650412-1', 'auto');
			ga('send', 'pageview');
		</script>

	<meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://boyleheightsbeat.com"><link rel="https://theeventscalendar.com/" href="https://boyleheightsbeat.com/wp-json/tribe/events/v1/" />		<script>
			document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );
		</script>
				<style>
			.no-js img.lazyload { display: none; }
			figure.wp-block-image img.lazyloading { min-width: 150px; }
							.lazyload { opacity: 0; }
				.lazyloading {
					border: 0 !important;
					opacity: 1;
					background: #F3F3F3 url('https://boyleheightsbeat.com/wp-content/plugins/wp-smushit/app/assets/images/smush-placeholder.png') no-repeat center !important;
					background-size: 16px auto !important;
				}
					</style>
		<style>.cb-base-color, .cb-overlay-stars .fa-star, #cb-vote .fa-star, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, .bbp-submit-wrapper button:visited, .buddypress .cb-cat-header #cb-cat-title a,  .buddypress .cb-cat-header #cb-cat-title a:visited, .woocommerce .star-rating:before, .woocommerce-page .star-rating:before, .woocommerce .star-rating span, .woocommerce-page .star-rating span, .woocommerce .stars a {
            color:#eb9812;
        }#cb-search-modal .cb-header, .cb-join-modal .cb-header, .lwa .cb-header, .cb-review-box .cb-score-box, .bbp-submit-wrapper button, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            border-color: #eb9812;
        }.cb-sidebar-widget .cb-sidebar-widget-title, .cb-multi-widget .tabbernav .tabberactive, .cb-author-page .cb-author-details .cb-meta .cb-author-page-contact, .cb-about-page .cb-author-line .cb-author-details .cb-meta .cb-author-page-contact, .cb-page-header, .cb-404-header, .cb-cat-header, #cb-footer #cb-widgets .cb-footer-widget-title span, #wp-calendar caption, .cb-tabs ul .current, .cb-tabs ul .ui-state-active, #bbpress-forums li.bbp-header, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li.selected, #buddypress div.item-list-tabs ul li.current, #buddypress .item-list-tabs ul li:hover, .woocommerce div.product .woocommerce-tabs ul.tabs li.active {
            border-bottom-color: #eb9812 ;
        }#cb-main-menu .current-post-ancestor, #cb-main-menu .current-menu-item, #cb-main-menu .current-menu-ancestor, #cb-main-menu .current-post-parent, #cb-main-menu .current-menu-parent, #cb-main-menu .current_page_item, #cb-main-menu .current-page-ancestor, #cb-main-menu .current-category-ancestor, .cb-review-box .cb-bar .cb-overlay span, #cb-accent-color, .cb-highlight, #buddypress button:hover, #buddypress a.button:hover, #buddypress a.button:focus, #buddypress input[type=submit]:hover, #buddypress input[type=button]:hover, #buddypress input[type=reset]:hover, #buddypress ul.button-nav li a:hover, #buddypress ul.button-nav li.current a, #buddypress div.generic-button a:hover, #buddypress .comment-reply-link:hover, #buddypress .activity-list li.load-more:hover, #buddypress #groups-list .generic-button a:hover {
            background-color: #eb9812;
        }</style><style type="text/css">
                                                 body, #respond { font-family: Roboto }
                                                 h1, h2, h3, h4, h5, h6, .h1, .h2, .h3, .h4, .h5, .h6, #cb-nav-bar #cb-main-menu ul li > a, .cb-author-posts-count, .cb-author-title, .cb-author-position, .search  .s, .cb-review-box .cb-bar, .cb-review-box .cb-score-box, .cb-review-box .cb-title, #cb-review-title, .cb-title-subtle, #cb-top-menu a, .tabbernav, #cb-next-link a, #cb-previous-link a, .cb-review-ext-box .cb-score, .tipper-positioner, .cb-caption, .cb-button, #wp-calendar caption, .forum-titles, .bbp-submit-wrapper button, #bbpress-forums li.bbp-header, #bbpress-forums fieldset.bbp-form .bbp-the-content-wrapper input, #bbpress-forums .bbp-forum-title, #bbpress-forums .bbp-topic-permalink, .widget_display_stats dl dt, .cb-lwa-profile .cb-block, #buddypress #members-list .cb-member-list-box .item .item-title, #buddypress div.item-list-tabs ul li, #buddypress .activity-list li.load-more, #buddypress a.activity-time-since, #buddypress ul#groups-list li div.meta, .widget.buddypress div.item-options, .cb-activity-stream #buddypress .activity-header .time-since, .cb-font-header, .woocommerce table.shop_table th, .woocommerce-page table.shop_table th, .cb-infinite-scroll a, .cb-no-more-posts { font-family:'Oswald', sans-serif; }
                     </style><style type="text/css">div .flex-viewport {
    max-height: 800px !important; }
    
    
.center {
    display: block;
    margin-left: auto;
    margin-right: auto;
    width: 50%;
}

p.orange-widget{
    background:#ff6a33;
    padding: 4px;
    color:white;
    font-size:16px;
    text-align:center;
    font-weight:bold;
}

.side-by-side-image {
    display: inline-block;
    margin-left: auto;
    margin-right: auto;
    height: 220px; 
    margin-top:0px;
    margin-bottom:0px;
    padding:0px;
}

#side-by-side-images{
    text-align:center;
}.entry-content a, .entry-content a:visited {color:#404040; }#cb-top-menu .cb-breaking-news ul li a { color:#404040; }body {color:#000000; }body { font-size: 18px; }@media only screen and (min-width: 1020px){ body { font-size: 18; }}.header { background-color: #ffffff; }</style><!-- end custom css --><style>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</style><script data-cfasync="false" type="text/javascript">if (window.addthis_product === undefined) { window.addthis_product = "wpp"; } if (window.wp_product_version === undefined) { window.wp_product_version = "wpp-6.2.6"; } if (window.addthis_share === undefined) { window.addthis_share = {}; } if (window.addthis_config === undefined) { window.addthis_config = {"data_track_clickback":true,"ignore_server_config":true,"ui_atversion":300}; } if (window.addthis_layers === undefined) { window.addthis_layers = {}; } if (window.addthis_layers_tools === undefined) { window.addthis_layers_tools = [{"share":{"counts":"none","numPreferredServices":6,"mobile":false,"position":"left","theme":"transparent"}},{"dock":{"follow":"off","buttonBarTheme":"light","buttonBarPosition":"bottom"}}]; } else { window.addthis_layers_tools.push({"share":{"counts":"none","numPreferredServices":6,"mobile":false,"position":"left","theme":"transparent"}}); window.addthis_layers_tools.push({"dock":{"follow":"off","buttonBarTheme":"light","buttonBarPosition":"bottom"}});  } if (window.addthis_plugin_info === undefined) { window.addthis_plugin_info = {"info_status":"enabled","cms_name":"WordPress","plugin_name":"Share Buttons by AddThis","plugin_version":"6.2.6","plugin_mode":"WordPress","anonymous_profile_id":"wp-15cf4a2071b4c1cbcf0062b752bdcc17","page_info":{"template":"posts","post_type":""},"sharing_enabled_on_post_via_metabox":false}; } 
                    (function() {
                      var first_load_interval_id = setInterval(function () {
                        if (typeof window.addthis !== 'undefined') {
                          window.clearInterval(first_load_interval_id);
                          if (typeof window.addthis_layers !== 'undefined' && Object.getOwnPropertyNames(window.addthis_layers).length > 0) {
                            window.addthis.layers(window.addthis_layers);
                          }
                          if (Array.isArray(window.addthis_layers_tools)) {
                            for (i = 0; i < window.addthis_layers_tools.length; i++) {
                              window.addthis.layers(window.addthis_layers_tools[i]);
                            }
                          }
                        }
                     },1000)
                    }());
                </script> <script data-cfasync="false" type="text/javascript" src="https://s7.addthis.com/js/300/addthis_widget.js#pubid=wp-15cf4a2071b4c1cbcf0062b752bdcc17" async="async"></script><link rel="icon" href="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-32x32.jpg" sizes="32x32" />
<link rel="icon" href="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-192x192.jpg" sizes="192x192" />
<link rel="apple-touch-icon" href="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-180x180.jpg" />
<meta name="msapplication-TileImage" content="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-270x270.jpg" />
		<!-- end head functions-->

	</head>

	<body class="post-template-default single single-post postid-35959 single-format-standard cb-sticky-mm cb-mod-zoom cb-m-sticky cb-tm-logo cb-sb-nar-embed-fw cb-cat-t-dark cb-mobm-light cb-gs-style-d cb-modal-dark cb-light-blog cb-sidebar-right cb-boxed cb-fis-type-standard cb-fis-tl-st-default tribe-no-js tribe-theme-parent-valenti tribe-theme-child-boyleheightsbeat">

        
	    <div id="cb-outer-container">

            
            <!-- Small-Screen Menu -->
            
            <div id="cb-mob-menu" class="clearfix cb-dark-menu">
                <a href="#" id="cb-mob-close" class="cb-link"><i class="fa cb-times"></i></a>

                                    <div class="cb-mob-menu-wrap">
                        <ul class="cb-small-nav"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16822"><a href="#">Topics</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16830"><a href="https://boyleheightsbeat.com/category/boyle-heights-in-focus/">In Focus</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4502"><a href="https://boyleheightsbeat.com/category/health/">Health /<br/> Environment</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4500"><a href="https://boyleheightsbeat.com/category/art-and-culture/">Culture</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4503"><a href="https://boyleheightsbeat.com/category/safety/">Safety</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4506"><a href="https://boyleheightsbeat.com/category/business-and-development/">Business /<br/>Development</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23033"><a href="https://boyleheightsbeat.com/category/boyle-heights-in-focus/">Youth Team Stories</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4728"><a href="https://boyleheightsbeat.com/category//community-feed/">Community Voices</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16829"><a href="https://boyleheightsbeat.com/events/">Community Events</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16832"><a href="https://boyleheightsbeat.com/events/community/">Add an Event</a></li>
	<li class="menu-item menu-item-type-yawp_wim menu-item-object-yawp_wim menu-item-16882">				<div class="yawp_wim_wrap">
					<div class="widget-area">
						<div id="tribe-events-adv-list-widget-8" class="yawp_wim_widget tribe-events-adv-list-widget">
		<!-- Event  -->
		<div class="type-tribe_events post-28627 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Fri			</span>
		
		<span class="list-daynumber">27</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/sabbath-services/2020-11-27/" rel="bookmark">Sabbath Services</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">November 27 @ 7:00 pm</span> - <span class="tribe-event-time">8:30 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-28688 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Dec			</span>
		
		<span class="list-daynumber">09</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/free-medicare-counseling-at-white-memorial-community-information-center-2/2020-12-09/" rel="bookmark">Free Medicare Counseling at White Memorial Community Information Center</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">December 9 @ 10:00 am</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<p class="tribe-events-widget-link">
		<a href="https://boyleheightsbeat.com/events/" rel="bookmark">
			View More&hellip;		</a>
	</p>
	
</div>					</div>
				</div>
				</li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16831"><a href="https://boyleheightsbeat.com/events/">View all events</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16828"><a title="get_involved" href="http://#">Get Involved</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16856"><a href="https://boyleheightsbeat.com/youth-reporter-application/">Youth Reporter Application</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16857"><a href="https://boyleheightsbeat.com/contribute/">Contribute a Story</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16859"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001I2RsqMRJGm_Os94HkTxBTNPHEm2FeBU_LYdGlgKWZQj0horGdZahUFD-R71PAS61biDHSTYqcgPkz6Ig5qD123-9Mwy6lEMOCDg7UYW8NB4K9g1QoB4zi8KH3UqjYnVCYqZojV9LlZybxYcmvwlZtxHt548os77PNC-psLnkgB-0hBrF77SteA%3D%3D">Subscribe to Our Newsletter</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children cb-has-children menu-item-17134"><a href="https://boyleheightsbeat.com/about-us/">About Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23125"><a href="https://boyleheightsbeat.com/youth-news-team-2017-2018/">Youth News Team</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16825"><a href="https://boyleheightsbeat.com/our-funder/">Our Funders</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16824"><a href="https://boyleheightsbeat.com/contact-us/">Contact Us</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16827"><a href="https://boyleheightsbeat.com/how-to-support/">Donate</a></li>
</ul>                    </div>
                            </div>

            <!-- /Small-Screen Menu -->

                    <div id="cb-search-modal" class="cb-s-modal cb-modal cb-dark-menu">
                        <div class="cb-search-box">
                            <div class="cb-header">
                                <div class="cb-title">Search</div>
                                <div class="cb-close">
                                    <span class="cb-close-modal cb-close-m"><i class="fa fa-times"></i></span>
                                </div>
                            </div><div class="header-search">
<script>
  (function() {
    var cx = '009240976895500230116:13vr2964l0y';
    var gcse = document.createElement('script');
    gcse.type = 'text/javascript';
    gcse.async = true;
    gcse.src = 'https://cse.google.com/cse.js?cx=' + cx;
    var s = document.getElementsByTagName('script')[0];
    s.parentNode.insertBefore(gcse, s);
  })();
</script>
<gcse:searchbox-only></gcse:searchbox-only>
</div></div></div>    		<div id="cb-container" class="wrap clearfix" itemscope itemtype="http://schema.org/Article">

                <header class="header clearfix wrap cb-logo-center">

                                            
                    
                        <div id="cb-logo-box" class="wrap clearfix">
                                            <div id="logo" >
                    <a href="https://boyleheightsbeat.com">
                        <img  alt="Boyle Heights Beat logo"  data-src="https://boyleheightsbeat.com/wp-content/uploads/2017/01/BoyleHeightsBeatLogoLG.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://boyleheightsbeat.com/wp-content/uploads/2017/01/BoyleHeightsBeatLogoLG.jpg" alt="Boyle Heights Beat logo" ></noscript>
                    </a>
                </div>
                                                                </div>

                     
                    

                                             <nav id="cb-nav-bar" class="clearfix cb-dark-menu">
                            <div id="cb-main-menu" class="cb-nav-bar-wrap clearfix wrap">
                                <ul class="nav main-nav wrap clearfix"><li id="menu-item-16822" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16822"><a href="#">Topics</a><div class="cb-links-menu"><ul class="cb-sub-menu">	<li id="menu-item-16830" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-16830"><a href="https://boyleheightsbeat.com/category/boyle-heights-in-focus/">In Focus</a></li>
	<li id="menu-item-4502" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4502"><a href="https://boyleheightsbeat.com/category/health/">Health /<br/> Environment</a></li>
	<li id="menu-item-4500" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4500"><a href="https://boyleheightsbeat.com/category/art-and-culture/">Culture</a></li>
	<li id="menu-item-4503" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-4503"><a href="https://boyleheightsbeat.com/category/safety/">Safety</a></li>
	<li id="menu-item-4506" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4506"><a href="https://boyleheightsbeat.com/category/business-and-development/">Business /<br/>Development</a></li>
	<li id="menu-item-23033" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-23033"><a href="https://boyleheightsbeat.com/category/boyle-heights-in-focus/">Youth Team Stories</a></li>
	<li id="menu-item-4728" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-4728"><a href="https://boyleheightsbeat.com/category//community-feed/">Community Voices</a></li>
</ul></div></li>
<li id="menu-item-16829" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16829"><a href="https://boyleheightsbeat.com/events/">Community Events</a><div class="cb-mega-menu"><ul class="cb-sub-menu">	<li id="menu-item-16832" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16832"><a href="https://boyleheightsbeat.com/events/community/">Add an Event</a></li>
	<li id="menu-item-16882" class="menu-item menu-item-type-yawp_wim menu-item-object-yawp_wim menu-item-16882">				<div class="yawp_wim_wrap">
					<div class="widget-area">
						<div id="tribe-events-adv-list-widget-8" class="yawp_wim_widget tribe-events-adv-list-widget">
		<!-- Event  -->
		<div class="type-tribe_events post-28627 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Fri			</span>
		
		<span class="list-daynumber">27</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/sabbath-services/2020-11-27/" rel="bookmark">Sabbath Services</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">November 27 @ 7:00 pm</span> - <span class="tribe-event-time">8:30 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-28688 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Dec			</span>
		
		<span class="list-daynumber">09</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/free-medicare-counseling-at-white-memorial-community-information-center-2/2020-12-09/" rel="bookmark">Free Medicare Counseling at White Memorial Community Information Center</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">December 9 @ 10:00 am</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<p class="tribe-events-widget-link">
		<a href="https://boyleheightsbeat.com/events/" rel="bookmark">
			View More&hellip;		</a>
	</p>
	
</div>					</div>
				</div>
				</li>
	<li id="menu-item-16831" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16831"><a href="https://boyleheightsbeat.com/events/">View all events</a></li>
</ul></div></li>
<li id="menu-item-16828" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children cb-has-children menu-item-16828"><a title="get_involved" href="http://#">Get Involved</a><div class="cb-mega-menu"><ul class="cb-sub-menu">	<li id="menu-item-16856" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16856"><a href="https://boyleheightsbeat.com/youth-reporter-application/">Youth Reporter Application</a></li>
	<li id="menu-item-16857" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16857"><a href="https://boyleheightsbeat.com/contribute/">Contribute a Story</a></li>
	<li id="menu-item-16859" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-16859"><a href="https://visitor.r20.constantcontact.com/manage/optin?v=001I2RsqMRJGm_Os94HkTxBTNPHEm2FeBU_LYdGlgKWZQj0horGdZahUFD-R71PAS61biDHSTYqcgPkz6Ig5qD123-9Mwy6lEMOCDg7UYW8NB4K9g1QoB4zi8KH3UqjYnVCYqZojV9LlZybxYcmvwlZtxHt548os77PNC-psLnkgB-0hBrF77SteA%3D%3D">Subscribe to Our Newsletter</a></li>
</ul></div></li>
<li id="menu-item-17134" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children cb-has-children menu-item-17134"><a href="https://boyleheightsbeat.com/about-us/">About Us</a><div class="cb-links-menu"><ul class="cb-sub-menu">	<li id="menu-item-23125" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23125"><a href="https://boyleheightsbeat.com/youth-news-team-2017-2018/">Youth News Team</a></li>
	<li id="menu-item-16825" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16825"><a href="https://boyleheightsbeat.com/our-funder/">Our Funders</a></li>
	<li id="menu-item-16824" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16824"><a href="https://boyleheightsbeat.com/contact-us/">Contact Us</a></li>
</ul></div></li>
<li id="menu-item-16827" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-16827"><a href="https://boyleheightsbeat.com/how-to-support/">Donate</a></li>
<li class="cb-icons"><ul id="cb-icons-wrap"><li class="cb-icon-search cb-menu-icon"><a href="#" data-cb-tip="Search" class="cb-tip-bot" id="cb-s-trigger"><i class="fa fa-search"></i></a></li></ul></li></ul>                            </div>
                        </nav>
                    
	 				
                                <!-- Secondary Menu -->
        <div id="cb-top-menu" class="clearfix cb-dark-menu">
            <div class="wrap cb-top-menu-wrap clearfix">

                <div class="cb-left-side cb-mob">
                                            <a href="#" id="cb-mob-open"><i class="fa fa-bars"></i></a>
                                    <div id="mob-logo" class="cb-top-logo">
                    <a href="https://boyleheightsbeat.com">
                        <img  alt=" logo" data-at2x="https://boyleheightsbeat.com/wp-content/uploads/2017/01/boyleheightsbeat-logo-small-mobile-retina.jpg" data-src="https://boyleheightsbeat.com/wp-content/uploads/2017/01/boyleheightsbeat-logo-small-mobile.jpg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="https://boyleheightsbeat.com/wp-content/uploads/2017/01/boyleheightsbeat-logo-small-mobile.jpg" alt=" logo" data-at2x="https://boyleheightsbeat.com/wp-content/uploads/2017/01/boyleheightsbeat-logo-small-mobile-retina.jpg"></noscript>
                    </a>
                </div>
            </div><ul class="cb-top-nav"><li id="menu-item-wpml-ls-3065-en" class="menu-item-language menu-item-language-current menu-item wpml-ls-slot-3065 wpml-ls-item wpml-ls-item-en wpml-ls-current-language wpml-ls-menu-item wpml-ls-first-item wpml-ls-last-item menu-item-type-wpml_ls_menu_item menu-item-object-wpml_ls_menu_item menu-item-wpml-ls-3065-en"><a title="English" href="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/"><span class="wpml-ls-native">English</span></a></li>
<li id="menu-item-16860" class="menu-item menu-item-type-custom menu-item-object-custom social-icon facebook menu-item-16860"><a title="facebook" href="https://www.facebook.com/Boyle-Heights-Beat-216347485050035/"><i class='fa-3x fa fa-facebook-square '></i><span class='fa-hidden'>Facebook</span></a></li>
<li id="menu-item-16861" class="menu-item menu-item-type-custom menu-item-object-custom social-icon twitter menu-item-16861"><a title="twitter" href="https://twitter.com/boyleheightsbt"><i class='fa-3x fa fa-twitter-square '></i><span class='fa-hidden'>Twitter</span></a></li>
<li id="menu-item-16862" class="menu-item menu-item-type-custom menu-item-object-custom social-icon youtube menu-item-16862"><a title="youtube" href="https://www.youtube.com/user/boyleheightsbeat"><i class='fa-3x fa fa-youtube-square '></i><span class='fa-hidden'>YouTube</span></a></li>
<li id="menu-item-17126" class="menu-item menu-item-type-custom menu-item-object-custom social-icon instagram menu-item-17126"><a title="instagram" href="https://www.instagram.com/boyleheightsbt/"><i class='fa-3x fa fa-instagram '></i><span class='fa-hidden'>Instagram</span></a></li>
</ul><div class="cb-mob-right"><a href="#" class="cb-small-menu-icons cb-small-menu-search" id="cb-s-trigger-sm"><i class="fa fa-search"></i></a></div>
            </div>
        </div>
        <!-- /Secondary Menu -->

                    
                    
	 				      <a href="#" id="cb-to-top" class="cb-base-color"><i class="fa fa-long-arrow-up"></i></a>

                    
                </header> <!-- end header -->            <div id="cb-content" class="wrap clearfix">

                
    <meta itemprop="datePublished" content="2020-11-20T22:30:50-08:00">
    <meta itemprop="dateModified" content="2020-11-20T22:44:28-08:00">
    <meta itemscope itemprop="mainEntityOfPage" itemtype="https://schema.org/WebPage" itemid="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/">
    <span class="cb-hide" itemscope itemprop="publisher" itemtype="https://schema.org/Organization">
        <meta itemprop="name" content="Boyle Heights Beat">
        <meta itemprop="url" content="https://boyleheightsbeat.com/wp-content/uploads/2017/01/BoyleHeightsBeatLogoLG.jpg">
        <span class="cb-hide" itemscope itemprop="logo" itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://boyleheightsbeat.com/wp-content/uploads/2017/01/BoyleHeightsBeatLogoLG.jpg">
        </span>
    </span>

    <meta itemprop="headline " content="2 women wanted for fleeing street race crash, leaving driver severely injured">

      <span class="cb-hide" itemscope itemtype="http://schema.org/ImageObject" itemprop="image" >
        <meta itemprop="url" content="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run.png">
        <meta itemprop="width" content="2560">
        <meta itemprop="height" content="1600">
    </span>


				<div id="main" class="cb-main clearfix">

						<article id="post-35959" class="clearfix post-35959 post type-post status-publish format-standard has-post-thumbnail hentry category-boyle-heights-in-focus category-safety tag-boyle-heights tag-hit-and-run">

                             <header id="cb-standard-featured"><div class="cb-mask"><img width="750" height="400"   alt="" loading="lazy" data-src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run-750x400.png" class="cb-fi-standard wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="750" height="400" src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/hit-and-run-750x400.png" class="cb-fi-standard wp-post-image" alt="" loading="lazy" /></noscript><div class="cb-image-credit"><i class="fa fa-camera"></i>Screenshot from surveillance video.</div></div><div id="cb-fis-wrap" class="cb-entry-header cb-fis cb-style-standard"><span class="cb-title-fi"><h1 class="entry-title cb-entry-title cb-single-title" itemprop="headline">2 women wanted for fleeing street race crash, leaving driver severely injured</h1><div class="cb-byline cb-font-header"><div class="cb-author cb-byline-element"><i class="fa fa-user"></i> <a href="https://boyleheightsbeat.com/author/boyle-heights-beat/">Boyle Heights Beat</a></div> <div class="cb-date cb-byline-element"><i class="fa fa-clock-o"></i> <time datetime="2020-11-20">November 20, 2020</time></div> <div class="cb-category cb-byline-element"><i class="fa fa-folder-o"></i>  <a href="https://boyleheightsbeat.com/category/boyle-heights-in-focus/" title="View all posts in Boyle Heights In Focus">Boyle Heights In Focus</a>,  <a href="https://boyleheightsbeat.com/category/safety/" title="View all posts in Safety">Safety</a></div><div class="cb-post-views cb-byline-element"><i class="fa fa-eye"></i> 138</div></div></div></header>
							<section class="cb-entry-content entry-content clearfix" itemprop="articleBody">

								<div class="at-above-post addthis_tool" data-url="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/"></div>
<p>Authorities are offering a $25,000 reward for anyone who can help identify and capture two women who fled the scene of a crash during an apparent speed race along the Los Angeles River early Wednesday, in which a driver was severely injured.</p>



<p>The women wanted by police were actually in the car hit in the crash. Police say they did not identify themselves or render aid to the injured driver as required by law.</p>



<figure class="wp-block-embed-twitter wp-block-embed is-type-rich is-provider-twitter"><div class="wp-block-embed__wrapper">
<blockquote class="twitter-tweet" data-width="550" data-dnt="true"><p lang="en" dir="ltr">Need to identify a driver of a Severe Injury Hit &amp; Run at a speed contest in <a href="https://twitter.com/LAPDHollenbeck?ref_src=twsrc%5Etfw">@LAPDHollenbeck</a>.  See video and Crime Alert Bulletin.  <a href="https://twitter.com/KCBSKCALDesk?ref_src=twsrc%5Etfw">@KCBSKCALDesk</a> <a href="https://twitter.com/NBCLA?ref_src=twsrc%5Etfw">@NBCLA</a> <a href="https://twitter.com/KTLAnewsdesk?ref_src=twsrc%5Etfw">@KTLAnewsdesk</a> <a href="https://twitter.com/ABC7?ref_src=twsrc%5Etfw">@ABC7</a> <a href="https://twitter.com/FOXLA?ref_src=twsrc%5Etfw">@FOXLA</a> <a href="https://twitter.com/TELEMUNDO52?ref_src=twsrc%5Etfw">@TELEMUNDO52</a> <a href="https://twitter.com/Noticias62TV?ref_src=twsrc%5Etfw">@Noticias62TV</a> <a href="https://twitter.com/Univision34LA?ref_src=twsrc%5Etfw">@Univision34LA</a> <a href="https://twitter.com/KNX1070?ref_src=twsrc%5Etfw">@KNX1070</a> <a href="https://twitter.com/latimes?ref_src=twsrc%5Etfw">@latimes</a> <a href="https://twitter.com/LaOpinionLA?ref_src=twsrc%5Etfw">@LaOpinionLA</a> <a href="https://twitter.com/bikinginla?ref_src=twsrc%5Etfw">@bikinginla</a> <a href="https://twitter.com/TheEastsiderLA?ref_src=twsrc%5Etfw">@TheEastsiderLA</a> <a href="https://t.co/D2FgTPTyQ1">pic.twitter.com/D2FgTPTyQ1</a></p>&mdash; LAPDCTD (@LAPDCTD24) <a href="https://twitter.com/LAPDCTD24/status/1329579022611714049?ref_src=twsrc%5Etfw">November 20, 2020</a></blockquote><script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script>
</div></figure>



<p>The crash occurred right after midnight on the 1800 block of North Myers – an industrial strip just east of the river bank and the railroad tracks that’s popular with cruisers and racers. According to LAPD, a green 1999 Honda Civic involved in a “speed contest&#8221; was traveling southbound when it collided with a gray 2006 Mercedes that was making a left turn.&nbsp;</p>



<p>Surveillance video released by the LAPD shows that after the collision, several people and other cars approached the Mercedes. Some of the people helped the driver and a passenger –both identified as white or Hispanic females– stagger out of the car.&nbsp; At one point a black Dodge Charger approaches the Mercedes and the two women enter the vehicle and flee the scene.</p>



<p>The video also shows that several people approached the Honda Civic and tried to help the driver. According to LAPD, paramedics transported the driver to a local area hospital with severe injuries.</p>



<p>“Drivers are reminded that if they become involved in a collision, they should pull over and stop as soon as it is safe to do so, notify emergency services, and remain at the scene to identify themselves,” an LAPD release said.</p>



<p>Anyone with information is&nbsp; urged to call Officer Mendoza at 213-833- 3713 or <a href="/cdn-cgi/l/email-protection" class="__cf_email__" data-cfemail="033031333233436f6273672d6c6d6f6a6d662d">[email&#160;protected]</a> Tipsters can also call the Central Traffic Division Watch Commander at 213-833-3746. Those wishing to report anonymously can call 800-222-TIPS.</p>
<!-- AddThis Advanced Settings above via filter on the_content --><!-- AddThis Advanced Settings below via filter on the_content --><!-- AddThis Advanced Settings generic via filter on the_content --><!-- AddThis Share Buttons above via filter on the_content --><!-- AddThis Share Buttons below via filter on the_content --><div class="at-below-post addthis_tool" data-url="https://boyleheightsbeat.com/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/"></div><!-- AddThis Share Buttons generic via filter on the_content -->
							</section> <!-- end article section -->

							<footer class="article-footer">
								<p class="cb-tags"> <a href="https://boyleheightsbeat.com/tag/boyle-heights/" rel="tag">Boyle Heights</a><a href="https://boyleheightsbeat.com/tag/hit-and-run/" rel="tag">hit-and-run</a></p><div id="cb-author-box" class="clearfix"><h3 class="cb-block-title">About The Author</h3><div class="cb-mask"><a href="https://boyleheightsbeat.com/author/boyle-heights-beat/"><img  width="120" height="120" alt="Boyle Heights Beat"  data-src="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-125x125.jpg" class="avatar avatar-120 wp-user-avatar wp-user-avatar-120 alignnone photo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://boyleheightsbeat.com/wp-content/uploads/2016/08/cropped-sunburst_BHB-125x125.jpg" width="120" height="120" alt="Boyle Heights Beat" class="avatar avatar-120 wp-user-avatar wp-user-avatar-120 alignnone photo" /></noscript></a></div><div class="cb-meta"><div class="cb-info"><div class="cb-author-title vcard" itemprop="author"><a href="https://boyleheightsbeat.com/author/boyle-heights-beat/"><span class="fn">Boyle Heights Beat</span></a></div></div><p class="cb-author-bio">Boyle Heights Beat is a bilingual community newspaper produced by its youth "por y para la comunidad". The newspaper and its sister website serve an immigrant neighborhood in East Los Angeles of just under 100,000. <a href="about-us/">Read more about our team</a></p></div></div><h3 class="cb-block-title">Related Articles</h3><div id="cb-related-posts" class="cb-related-posts-block cb-post-end-block clearfix"><h3 class="cb-block-title">Related Posts</h3><ul>                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-1">
                                <div class="cb-mask" style="background-color:#eb9812;"><a href="https://boyleheightsbeat.com/gomez-in-tight-race-to-represent-34th-district-in-congress-santiago-returned-to-assembly-in-53rd/"><img width="360" height="240"   alt="" loading="lazy" data-srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" data-src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="360" height="240" src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" loading="lazy" srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/11/Candiates-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://boyleheightsbeat.com/gomez-in-tight-race-to-represent-34th-district-in-congress-santiago-returned-to-assembly-in-53rd/">Gómez in tight race to represent 34th District in Congress; Santiago returned to Assembly in 53rd</a></h4>
                                                                     </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-2">
                                <div class="cb-mask" style="background-color:#eb9812;"><a href="https://boyleheightsbeat.com/coronavirus-in-boyle-heights-and-east-la/"><img width="360" height="240"   alt="" loading="lazy" data-srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" data-src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="360" height="240" src="https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" loading="lazy" srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/11/September-22-2020-71-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://boyleheightsbeat.com/coronavirus-in-boyle-heights-and-east-la/">Coronavirus in Boyle Heights and East LA</a></h4>
                                                                     </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-1">
                                <div class="cb-mask" style="background-color:#eb9812;"><a href="https://boyleheightsbeat.com/weekend-shootings-in-boyle-heights-target-homeless-residents-leave-one-dead/"><img width="360" height="240"   alt="" loading="lazy" data-srcset="https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-360x240.jpg 360w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-300x201.jpg 300w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-600x400.jpg 600w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime.jpg 640w" sizes="(max-width: 360px) 100vw, 360px" data-src="https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="360" height="240" src="https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-360x240.jpg" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" loading="lazy" srcset="https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-360x240.jpg 360w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-300x201.jpg 300w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime-600x400.jpg 600w, https://boyleheightsbeat.com/wp-content/uploads/2016/01/crime.jpg 640w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://boyleheightsbeat.com/weekend-shootings-in-boyle-heights-target-homeless-residents-leave-one-dead/">Weekend shootings in Boyle Heights target homeless residents, leave one dead</a></h4>
                                                                     </div>
                            </li>
                            <li class="cb-style-overlay cb-grid-entry cb-related-post no-2">
                                <div class="cb-mask" style="background-color:#eb9812;"><a href="https://boyleheightsbeat.com/for-those-who-cant-vote-other-ways-of-being-heard/"><img width="360" height="240"   alt="" loading="lazy" data-srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" data-src="https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img width="360" height="240" src="https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-360x240.png" class="attachment-cb-360-240 size-cb-360-240 wp-post-image" alt="" loading="lazy" srcset="https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-360x240.png 360w, https://boyleheightsbeat.com/wp-content/uploads/2020/10/Voting-Protest-600x400.png 600w" sizes="(max-width: 360px) 100vw, 360px" /></noscript></a></div>
                                 <div class="cb-meta cb-article-meta">
                                     <h4 class="h3 cb-post-title"><a href="https://boyleheightsbeat.com/for-those-who-cant-vote-other-ways-of-being-heard/">For those who can’t vote, other ways of being heard</a></h4>
                                                                     </div>
                            </li>
</ul></div>
							</footer> <!-- end article footer -->

							



	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title">Leave a Reply <small><a rel="nofollow" id="cancel-comment-reply-link" href="/2-women-wanted-for-fleeing-street-race-crash-leaving-driver-severely-injured/#respond" style="display:none;">Cancel Reply</a></small></h3><form action="https://boyleheightsbeat.com/wp-comments-post.php" method="post" id="commentform" class="comment-form"><p class="comment-notes">Your email address will not be published.</p><p class="comment-form-comment"><label for="comment">Comment</label><textarea id="comment" name="comment" cols="45" rows="8" aria-required="true"></textarea></p><input name="wpml_language_code" type="hidden" value="en" /><p class="comment-form-author"><label for="author">Name<span class="required">*</span></label> <input id="author" name="author" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-email"><label for="email">Email<span class="required">*</span></label> <input id="email" name="email" type="text" value="" size="30" aria-required='true' /></p>
<p class="comment-form-url"><label for="url">Website</label><input id="url" name="url" type="text" value="" size="30" /></p>
<p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='35959' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p><p style="display: none;"><input type="hidden" id="akismet_comment_nonce" name="akismet_comment_nonce" value="87af825065" /></p><p style="display: none;"><input type="hidden" id="ak_js" name="ak_js" value="200"/></p></form>	</div><!-- #respond -->
	
						</article> <!-- end article -->

					
					
				</div> <!-- end #main -->

				<aside class="cb-sidebar clearfix" role="complementary">


<div id="wpp-2" class="cb-sidebar-widget popular-posts">
<h3 class="cb-sidebar-widget-title">Most Popular Stories</h3>
<!-- WordPress Popular Posts -->

<ul class="wpp-list">
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/fired-el-tepeyac-cook-claims-he-was-forced-to-train-his-younger-replacement/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/35897-featured-110x110.jpg" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/fired-el-tepeyac-cook-claims-he-was-forced-to-train-his-younger-replacement/" class="wpp-post-title" target="_self">Fired El Tepeyac cook claims he was forced to train his younger replacement</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/yes-boyle-heights-that-was-bad-bunny/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/35628-featured-110x110.jpg" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/yes-boyle-heights-that-was-bad-bunny/" class="wpp-post-title" target="_self">Yes, Boyle Heights, that was Bad Bunny</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/theyre-young-latino-and-voting-for-trump-in-2020/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/35748-featured-110x110.jpeg" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/theyre-young-latino-and-voting-for-trump-in-2020/" class="wpp-post-title" target="_self">They’re young, Latino, and voting for Trump in 2020</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/new-overnight-stay-at-home-order-starts-saturday-in-la-county-and-most-of-the-rest-of-california/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/35946-featured-110x110.jpg" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/new-overnight-stay-at-home-order-starts-saturday-in-la-county-and-most-of-the-rest-of-california/" class="wpp-post-title" target="_self">New overnight stay-at-home order starts Saturday in LA County (and most of the rest of California)</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/drive-through-covid-19-testing-site-to-open-at-east-la-college/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/29940-featured-110x110.png" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/drive-through-covid-19-testing-site-to-open-at-east-la-college/" class="wpp-post-title" target="_self">Drive-through COVID-19 testing site to open at East LA College</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/coronavirus-in-boyle-heights-and-east-la/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/30175-featured-110x110.png" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/coronavirus-in-boyle-heights-and-east-la/" class="wpp-post-title" target="_self">Coronavirus in Boyle Heights and East LA</a></li>
<li style="padding-bottom:6px;font-size:medium"><a href="https://boyleheightsbeat.com/forgotten-cast-aside-being-a-minority-in-a-mexican-neighborhood/" target="_self"><img data-img-src="https://boyleheightsbeat.com/wp-content/uploads/wordpress-popular-posts/28932-featured-110x110.jpg" width="110" height="110" alt="" class="wpp-thumbnail wpp_featured wpp-lazyload wpp_cached_thumb" /></a> <a href="https://boyleheightsbeat.com/forgotten-cast-aside-being-a-minority-in-a-mexican-neighborhood/" class="wpp-post-title" target="_self">Forgotten, cast aside: being a minority in a Mexican neighborhood</a></li>

</ul>

</div>
<div id="tribe-events-adv-list-widget-5" class="cb-sidebar-widget tribe-events-adv-list-widget"><h3 class="cb-sidebar-widget-title">Upcoming Events</h3>
		<!-- Event  -->
		<div class="type-tribe_events post-28627 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Fri			</span>
		
		<span class="list-daynumber">27</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/sabbath-services/2020-11-27/" rel="bookmark">Sabbath Services</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">November 27 @ 7:00 pm</span> - <span class="tribe-event-time">8:30 pm</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<!-- Event  -->
		<div class="type-tribe_events post-28688 tribe-clearfix">
			
<div class="tribe-mini-calendar-event event--1 ">
	
	<div class="list-date">
					<span class="list-dayname">
				Dec			</span>
		
		<span class="list-daynumber">09</span>
		</div>

		<div class="list-info">
						<h2 class="tribe-events-title">
					<a href="https://boyleheightsbeat.com/event/free-medicare-counseling-at-white-memorial-community-information-center-2/2020-12-09/" rel="bookmark">Free Medicare Counseling at White Memorial Community Information Center</a>
			</h2>
			
			
			<div class="tribe-events-duration">
				<span class="tribe-event-date-start">December 9 @ 10:00 am</span>			</div>

			
			<!-- // Price, Venue Name, Street, City, State or Province, Postal Code, Country, Venue Phone, Organizer Name-->
			
					</div>
	</div> <!-- .list-info -->
		</div>

		
	
		<p class="tribe-events-widget-link">
		<a href="https://boyleheightsbeat.com/events/" rel="bookmark">
			View More&hellip;		</a>
	</p>
	
</div><script data-cfasync="false" src="/cdn-cgi/scripts/5c5dd728/cloudflare-static/email-decode.min.js"></script><script type="application/ld+json">
[{"@context":"http://schema.org","@type":"Event","name":"Sabbath Services","description":"&lt;p&gt;Come East to observe the Sabbath at Temple B\\'nai Emet, 482 N. Garfield Ave., Montebello, CA 90640. Services each Friday night at 7:00 p.m. and on Saturday mornings starting at 9:00 a. m. In order to say Kaddish and read the Torah, with Spanish translation available, our Conservative Jewish congregation welcomes YOU to \\'make a [&hellip;]&lt;/p&gt;\\n","url":"https://boyleheightsbeat.com/event/sabbath-services/2020-11-27/","startDate":"2020-11-27T19:00:00-08:00","endDate":"2020-11-27T20:30:00-08:00","performer":"Organization"},{"@context":"http://schema.org","@type":"Event","name":"Free Medicare Counseling at White Memorial Community Information Center","description":"&lt;p&gt;HICAP counselor Janice Torres offers free Medicare options counseling at the White Memorial Community Information Center. The statewide HICAP (Health Insurance Counseling and Advocacy Program) trains volunteers to provide unbiased information about Medicare to their fellow community members. Ms. Torres can help with topics including: Medicare costs and benefits, Medicare prescription drug coverage, Medicare Advantage [&hellip;]&lt;/p&gt;\\n","url":"https://boyleheightsbeat.com/event/free-medicare-counseling-at-white-memorial-community-information-center-2/2020-12-09/","startDate":"2020-12-09T10:00:00-08:00","endDate":"2020-12-09T10:00:00-08:00","performer":"Organization"}]
</script>
</aside>


			</div> <!-- end #cb-content -->

     			<footer id="cb-footer" class=" wrap" role="contentinfo">

    				<div id="cb-widgets" class="cb-footer-b cb-footer-wrap wrap clearfix">

                                                    <div class="cb-one cb-column clearfix">
                                <div id="custom_html-4" class="widget_text cb-footer-widget widget_custom_html"><h3 class="cb-footer-widget-title"><span>Connect</span></h3><div class="textwidget custom-html-widget"><ul>	
<li><a href="/pick-up-a-newspaper-here">Pick Up a Newspaper</a></li></ul></div></div><div id="text-40" class="cb-footer-widget widget_text">			<div class="textwidget"><script>(function() {
	window.mc4wp = window.mc4wp || {
		listeners: [],
		forms: {
			on: function(evt, cb) {
				window.mc4wp.listeners.push(
					{
						event   : evt,
						callback: cb
					}
				);
			}
		}
	}
})();
</script><!-- Mailchimp for WordPress v4.7.6 - https://wordpress.org/plugins/mailchimp-for-wp/ --><form id="mc4wp-form-1" class="mc4wp-form mc4wp-form-30326 mc4wp-form-theme mc4wp-form-theme-dark" method="post" data-id="30326" data-name="Subscribe to our email" ><div class="mc4wp-form-fields">    <div class="email-subscribe-form-group">
<p class="widget-subheading">
  Sign Up For Our Emails
</p>
<p>
	<label class="subscribe-form-label">Email address: 
		<input type="email" name="EMAIL" placeholder="Your email address" required class="subscribe-form-textinput"/>
</label>
</p>

<p>
	<input type="submit" value="Sign up" class="subscribe-submit"/>
</p></div></div><label style="display: none !important;">Leave this field empty if you're human: <input type="text" name="_mc4wp_honeypot" value="" tabindex="-1" autocomplete="off" /></label><input type="hidden" name="_mc4wp_timestamp" value="1606003113" /><input type="hidden" name="_mc4wp_form_id" value="30326" /><input type="hidden" name="_mc4wp_form_element_id" value="mc4wp-form-1" /><div class="mc4wp-response"></div></form><!-- / Mailchimp for WordPress Plugin -->
</div>
		</div>                            </div>
                                                                            <div class="cb-two cb-column clearfix">
                                <div id="custom_html-5" class="widget_text cb-footer-widget widget_custom_html"><h3 class="cb-footer-widget-title"><span>Support Us</span></h3><div class="textwidget custom-html-widget"><p style="color:#cccccc">Your tax-deductible contributions help support youth journalism in the Boyle Heights community. <b><a href="/how-to-support">Donate Online</a></b></p></div></div>                            </div>
                                                                            <div class="cb-three cb-column clearfix">
                                <div id="text-35" class="cb-footer-widget widget_text"><h3 class="cb-footer-widget-title"><span>Get Involved</span></h3>			<div class="textwidget"><ul>
<li><a href="/youth-reporter-application">Apply to Join the Youth Team</a></li>
<li><a href="/contribute">Become an Adult Contributor</a></li>
<li><a href="/contribute">Share Your Story</a></li>
<li><a href="/events/community/add">Add a Community Event</a></li>
</ul>
</div>
		</div>                            </div>
                                                                            <div class="cb-four cb-column clearfix">
                                <div id="text-38" class="cb-footer-widget widget_text"><h3 class="cb-footer-widget-title"><span>About Us</span></h3>			<div class="textwidget"><ul>
<li><a href="/about-us">Who We Are</a></li>
<li><a href="/youth-news-team-2017-2018">Youth Team</a></li>
<li><a href="/our-funder">Our Funders</a></li>
<li><a href="/contact-us">Contact Us</a></li>
</ul>
</div>
		</div>                            </div>
                        
                    </div>

                    
                        <div class="cb-footer-lower clearfix">

                            <div class="wrap clearfix">

                                <div class="cb-copyright">Copyright © 2020 Boyle Heights Beat. All rights reserved.</div>

        						
           					</div>

        				</div>
    				
    			</footer> <!-- end footer -->

    		</div> <!-- end #cb-container -->

		</div> <!-- end #cb-outer-container -->

        <span id="cb-overlay"></span>

				<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script>(function() {function maybePrefixUrlField() {
	if (this.value.trim() !== '' && this.value.indexOf('http') !== 0) {
		this.value = "http://" + this.value;
	}
}

var urlFields = document.querySelectorAll('.mc4wp-form input[type="url"]');
if (urlFields) {
	for (var j=0; j < urlFields.length; j++) {
		urlFields[j].addEventListener('blur', maybePrefixUrlField);
	}
}
})();</script>        <script type="text/javascript">
            (function(){
                document.addEventListener('DOMContentLoaded', function(){
                    let wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                    if ( wpp_widgets ) {
                        for (let i = 0; i < wpp_widgets.length; i++) {
                            let wpp_widget = wpp_widgets[i];
                            WordPressPopularPosts.theme(wpp_widget);
                        }
                    }
                });
            })();
        </script>
                <script>
            var WPPImageObserver = null;

            function wpp_load_img(img) {
                if ( ! 'imgSrc' in img.dataset || ! img.dataset.imgSrc )
                    return;

                img.src = img.dataset.imgSrc;

                if ( 'imgSrcset' in img.dataset ) {
                    img.srcset = img.dataset.imgSrcset;
                    img.removeAttribute('data-img-srcset');
                }

                img.classList.remove('wpp-lazyload');
                img.removeAttribute('data-img-src');
                img.classList.add('wpp-lazyloaded');
            }

            function wpp_observe_imgs(){
                let wpp_images = document.querySelectorAll('img.wpp-lazyload'),
                    wpp_widgets = document.querySelectorAll('.popular-posts-sr');

                if ( wpp_images.length || wpp_widgets.length ) {
                    if ( 'IntersectionObserver' in window ) {
                        WPPImageObserver = new IntersectionObserver(function(entries, observer) {
                            entries.forEach(function(entry) {
                                if (entry.isIntersecting) {
                                    let img = entry.target;
                                    wpp_load_img(img);
                                    WPPImageObserver.unobserve(img);
                                }
                            });
                        });

                        if ( wpp_images.length ) {
                            wpp_images.forEach(function(image) {
                                WPPImageObserver.observe(image);
                            });
                        }

                        if ( wpp_widgets.length ) {
                            for (var i = 0; i < wpp_widgets.length; i++) {
                                let wpp_widget_images = wpp_widgets[i].querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widgets[i].shadowRoot ) {
                                    wpp_widget_images = wpp_widgets[i].shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    wpp_widget_images.forEach(function(image) {
                                        WPPImageObserver.observe(image);
                                    });
                                }
                            }
                        }
                    } /** Fallback for older browsers */
                    else {
                        if ( wpp_images.length ) {
                            for (var i = 0; i < wpp_images.length; i++) {
                                wpp_load_img(wpp_images[i]);
                                wpp_images[i].classList.remove('wpp-lazyloaded');
                            }
                        }

                        if ( wpp_widgets.length ) {
                            for (var j = 0; j < wpp_widgets.length; j++) {
                                let wpp_widget = wpp_widgets[j],
                                    wpp_widget_images = wpp_widget.querySelectorAll('img.wpp-lazyload');

                                if ( ! wpp_widget_images.length && wpp_widget.shadowRoot ) {
                                    wpp_widget_images = wpp_widget.shadowRoot.querySelectorAll('img.wpp-lazyload');
                                }

                                if ( wpp_widget_images.length ) {
                                    for (var k = 0; k < wpp_widget_images.length; k++) {
                                        wpp_load_img(wpp_widget_images[k]);
                                        wpp_widget_images[k].classList.remove('wpp-lazyloaded');
                                    }
                                }
                            }
                        }
                    }
                }
            }

            document.addEventListener('DOMContentLoaded', function() {
                wpp_observe_imgs();

                // When an ajaxified WPP widget loads,
                // Lazy load its images
                document.addEventListener('wpp-onload', function(){
                    wpp_observe_imgs();
                });
            });
        </script>
        <script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"be2fe96d0d","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script><script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.6.1' id='smush-lazy-load-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/comment-reply.min.js?ver=5.5.3' id='comment-reply-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/themes/valenti/library/js/cookie.min.js?ver=5.4' id='cb-cookie-js'></script>
<script type='text/javascript' id='cb-js-ext-js-extra'>
/* <![CDATA[ */
var cbExt = {"cbSS":"on","cbLb":"on"};
/* ]]> */
</script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/themes/valenti/library/js/jquery.ext.js?ver=5.4' id='cb-js-ext-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/jquery/ui/core.min.js?ver=1.11.4' id='jquery-ui-core-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/jquery/ui/widget.min.js?ver=1.11.4' id='jquery-ui-widget-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/jquery/ui/tabs.min.js?ver=1.11.4' id='jquery-ui-tabs-js'></script>
<script type='text/javascript' id='cb-js-js-extra'>
/* <![CDATA[ */
var cbScripts = {"cbUrl":"https:\/\/boyleheightsbeat.com\/wp-admin\/admin-ajax.php","cbPostID":"35959","cbSlider":["600",true,"7000"]};
/* ]]> */
</script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/themes/valenti/library/js/cb-scripts.min.js?ver=5.4' id='cb-js-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-includes/js/wp-embed.min.js?ver=5.5.3' id='wp-embed-js'></script>
<script async="async" type='text/javascript' src='https://boyleheightsbeat.com/wp-content/plugins/akismet/_inc/form.js?ver=4.1.4' id='akismet-form-js'></script>
<script type='text/javascript' src='https://boyleheightsbeat.com/wp-content/plugins/mailchimp-for-wp/assets/js/forms.min.js?ver=4.7.6' id='mc4wp-forms-api-js'></script>

	</body>

</html> <!-- The End. what a ride! -->